IntelliJ Platform SDK DevGuide

Edit page

Incompatible Changes in IntelliJ Platform and Plugins API

IntelliJ API may be occasionally changed between releases, leading to incompatibilities of existing plugins with newer IDE builds.

Compatibility with newer IDEs can easily be verified for plugins hosted on the JetBrains plugin repository using the built-in Plugin Verifier.

For non-public plugins, intellij-plugin-verifier can be used standalone as well.

Consider using the following IDE inspections to get additional alerts about code that uses unstable API features:

  • JVM languages | Unstable API Usage
  • JVM languages | Unstable type is used in signature

The following pages list the breaking changes in IDE/plugin releases with required/recommended steps to take by plugin authors.

Last modified: 24 January 2020